Login | Register
My pages Projects Community openCollabNet

Discussions > users > Install problem > Reply to message

Reply to message

* = Required fields
* Subject
* Body
Send reply to
Author (directly in email)
Please type the letters in the image above.

Original message

Author Jameel Khalfan <jkhalfan@MIT.EDU>
Full name Jameel Khalfan <jkhalfan@MIT.EDU>
Date 2004-05-28 01:15:34 PDT
Message I am using Eyebrowse 1.1 final with Apache 1.3.27, Jserv 1.1, JSDK 2.0, and am experiencing a problem with eyebrowse. When I try accessing the SummarizeList, or any eyebrowse servlet, I keep getting the folloiwing error message in my Jserv logs:

[28/05/2004 04:08:51:615 EDT] java.lang.NoSuchMethodError: javax.servlet.Servle​tContext.getInitPara​meter(Ljava/lang/Str​ing;)Ljava/lang/Stri​ng;
        at org.tigris.eyebrowse​.servlets.EyebrowseS​ervlet.loadConfigura​tion(EyebrowseServle​t.java:160)
        at org.apache.velocity.​servlet.VelocityServ​let.initVelocity(Vel​ocityServlet.java)
        at org.apache.velocity.​servlet.VelocityServ​let.init(VelocitySer​vlet.java)
        at org.apache.jserv.JSe​rvServletManager.loa​d_init(JServServletM​anager.java:579)
        at org.apache.jserv.JSe​rvServletManager.loa​dServlet(JServServle​tManager.java:498)
        at org.apache.jserv.JSe​rvConnection.process​Request(JServConnect​ion.java:269)
        at org.apache.jserv.JSe​rvConnection.run(JSe​rvConnection.java:18​8)
        at java.lang.Thread.run​(Thread.java:534)

I tried adding a call to getinitparameter to IsItWorking.java, recompiled it, and ran the isitowrking test again, and it worked fine without crashing, so it seems that there is something wrong with eyebrowse or the way I have configured eyebrowse.

Does anyone have any suggestions?


Jameel Khalfan