Login | Register
My pages Projects Community openCollabNet

Discussions > users > Installation problem

eyebrowse
Discussion topic

Back to topic list

Installation problem

Reply

Author BLIS-Webmaster <webmaster at blis-project dot org>
Full name BLIS-Webmaster <webmaster at blis-project dot org>
Date 2002-08-29 15:06:36 PDT
Message Hi all,

First I would like to congratulate you for the effort you are currently doing for this very good and promising mail archiver.
I'm the webmaster of an international association in the building industry and I have some majordomo mailing lists that I would like to archive online.

I'm quite a newbie with this things relative to Tomcat and servlets but I try to do my best to catch up :).

I'm running a Linux server, with Apache and jdk 1.3.1, ant, etc..

As I have an already working installation of Scarab 1.0b8, I thought that I could easily add Eyebrowse to the Scarab installation but I'm facing some problems to run Eyebrowse

Here is the process I followed to setup my installation of Eyebrowse:

-1- I have first downloaded the eyebrowse-1-1.zip file from the "File sharing" section.

-2- Unzipped this file in a temp directory and figured out that it seemed actually to be a compiled and ready to use version

-3- then I copied the folder eyebrowse/ in the same directory of webapps/ where scarab currently is so that I have now the following structure:
target/
   ....
    webapps/
            eyebrowse/
                WEB-INF/
                 classes/
                 ....
            scarab/
                 WEB-INF/
                 classes/
                 ....

-4- I added the following context for eyebrowse in server.xml in conf/
<Context path="/eyebrowse" docBase="eyebrowse" reloadable="true" debug="0">
           <Logger className="org.apach​e.catalina.logger.Fi​leLogger"
                     prefix="eyebrowse_log." suffix=".txt"
                  timestamp="true"/>
           <Loader checkInterval="1"
                className="org.apach​e.catalina.loader.We​bappLoader"/>
           <Manager debug="99"/>
</Context>

-5- Then I restarted CATALINA and everything went ok.

-6- I created the eyebrowse database, created the tables, populated it using the Perl scripts and could check that there was really the archive of my mailing list in the DB now.

-7- Then I point my internet browser to the following address http://www.blis-proj​ect.org:8081/eyebrow​se/ and get the following errors:

Apache Tomcat/4.0.3 - HTTP Status 500 -
--------------------​--------------------​--------------------​--------------------​
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception

javax.servlet.ServletException: Servlet.init() for servlet ViewLists threw exception
 at org.apache.catalina.​core.StandardWrapper​.loadServlet(Standar​dWrapper.java:935)
 at org.apache.catalina.​core.StandardWrapper​.allocate(StandardWr​apper.java:653)
 at org.apache.catalina.​core.StandardWrapper​Valve.invoke(Standar​dWrapperValve.java:2​14)
 at org.apache.catalina.​core.StandardPipelin​e.invokeNext(Standar​dPipeline.java:566)
 at org.apache.catalina.​core.StandardPipelin​e.invoke(StandardPip​eline.java:472)
....

root cause

java.lang.NoClassDefFoundError: org/apache/velocity/​runtime/RuntimeSingl​eton
 at
 at org.apache.velocity.​servlet.VelocityServ​let.initVelocity(Vel​ocityServlet.java:23​2)
 at org.apache.velocity.​servlet.VelocityServ​let.init(VelocitySer​vlet.java:198)
 at org.apache.catalina.​core.StandardWrapper​.loadServlet(Standar​dWrapper.java:916)
 at org.apache.catalina.​core.StandardWrapper​.allocate(StandardWr​apper.java:653)
 at org.apache.catalina.​core.StandardWrapper​Valve.invoke(Standar​dWrapperValve.java:2​14)
 ....

Actually you can visit this address to see the complete message.
Remember that my Scarab installation is working well: http://www.blis-proj​ect.org:8081/scarab/​servlet/scarab

What am I missing in the installation process? (I'm a stupid newbie I know ;) )
Any idea?

Thanks in advance for your help.

Regards,
Patrick Houbaux
- BLIS Webmaster.





--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@ey​ebrowse.tigris.org
For additional commands, e-mail: users-help at eyebrowse dot tigris dot org

« Previous message in topic | 1 of 12 | Next message in topic »

Messages

Show all messages in topic

Installation problem BLIS-Webmaster <webmaster at blis-project dot org> BLIS-Webmaster <webmaster at blis-project dot org> 2002-08-29 15:06:36 PDT
     Re: Installation problem patmonardo Pat Monardo 2002-08-29 15:29:08 PDT
         Re: Installation problem BLIS-Webmaster <webmaster at blis-project dot org> BLIS-Webmaster <webmaster at blis-project dot org> 2002-08-29 21:32:25 PDT
             Re: Installation problem patmonardo Pat Monardo 2002-08-29 22:08:37 PDT
                 Re: Installation problem BLIS-Webmaster <webmaster at blis-project dot org> BLIS-Webmaster <webmaster at blis-project dot org> 2002-08-30 09:47:57 PDT
                     Re: Installation problem dlr Daniel Rall 2002-09-03 11:52:27 PDT
             Re: Installation problem Eric Weidner <esw at pumavision dot net> Eric Weidner <esw at pumavision dot net> 2002-08-29 21:47:49 PDT
                 Re: Installation problem dlr Daniel Rall 2002-09-24 21:54:10 PDT
         Re: Installation problem dlr Daniel Rall 2002-09-03 11:47:48 PDT
     Re: Installation problem Frans Thamura <java at intercitra dot com> Frans Thamura <java at intercitra dot com> 2002-08-30 00:18:05 PDT
         Re: Installation problem BLIS-Webmaster <webmaster at blis-project dot org> BLIS-Webmaster <webmaster at blis-project dot org> 2002-08-30 09:59:15 PDT
     Re: Installation problem dlr Daniel Rall 2002-09-03 11:47:09 PDT
Messages per page: