Login | Register
My pages Projects Community openCollabNet

Discussions > users > JDK requirement

eyebrowse
Discussion topic

Back to topic list

JDK requirement

Reply

Author dlr
Full name Daniel Rall
Date 2003-02-25 11:00:38 PST
Message Hi all! I'm interested in increasing the minimum JDK version required
to run Eyebrowse from 1.2+ to 1.3+. With multiple revisions of JDK
1.4 already shipping and providing better BSD-compatibility, this
doesn't seem like such an unreasonable request.

Specifically, I'd like to use the java.util.Timer and
java.util.TimerTask classes (pointed out to me by Bijal Modi) which
were introduced in JDK 1.3 as a more elegant method of implementing
periodic index updates. I recently added a rough cut at this,
org.tigris.eyebrowse​.servlets.IndexerSer​vlet, but after looking over
Timer, have decided that using it in the implementation will result in
a much cleaner and more cohesive product.

What do y'all think?
--

Daniel Rall <dlr at finemaltcoding dot com>

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@ey​ebrowse.tigris.org
For additional commands, e-mail: users-help at eyebrowse dot tigris dot org

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

JDK requirement dlr Daniel Rall 2003-02-25 11:00:38 PST
Messages per page: